Olark Native for iOS performance issue
Incident Report for Olark Live Chat
Postmortem

On April 14th we received reports from our mobile beta app iOS users that they weren’t seeing a badge to indicate the number of unread messages or notifications regarding their agent status changes.

Our team tracked the issue to a downstream provider and notified the provider. The provider acknowledged the issue and was able to resolve it on April 15, which, in turn, restored notifications in Olark Mobile on iOS.

This issue revealed a gap in our internal monitoring in this area. Our mobile team is working to implement additional monitoring so that we can detect these sorts of issues quickly should they ever happen again.

Posted May 10, 2021 - 11:37 EDT

Resolved
Our service provider has released a fix and we believe the issues we were seeing have been resolved.
Posted Apr 15, 2021 - 10:55 EDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2021 - 19:32 EDT
Investigating
Our native mobile app (currently in BETA) for iOS users is currently experiencing issues with notifications and status changes. We've determined this issue to be caused by a technical problem with our messaging provider. We are working with this provider to resolve this issue as quickly as possible.

Some affected functionality includes: unread message badges, desktop/mobile status changes, and desktop/mobile interactions.

Chat messages between visitors and agents are still being delivered properly but you may wish to use an alternate chat console (such as chat.olark.com) until this issue can be resolved. We'll update here as we have additional information.
Posted Apr 14, 2021 - 18:33 EDT
This incident affected: Olark Mobile App (BETA).